Documentation

This is machine translation

Translated by Microsoft
Mouse over text to see original. Click the button below to return to the English verison of the page.

我们为许可用户提供了部分翻译好的中文文档。您只需登录便可查阅这些文档

hgsave

Save graphics object hierarchy to file

Syntax

hgsave('filename')
hgsave(h,'filename')
hgsave(...,'-v6')
hgsave(...,'-v7.3')

Description

    Note:   hgsave is not recommended. Use savefig instead.

hgsave('filename') saves the current figure to a file named filename.

hgsave(h,'filename') saves the objects identified by the array of handles h to a file named filename. If you do not specify an extension for filename, then the extension .fig is appended. If h is a vector, none of the handles in h may be ancestors or descendents of any other handles in h.

hgsave(...,'-v6') saves the FIG-file in a format that can be loaded by versions prior to MATLAB® 7.

hgsave(...,'-v7.3') saves the FIG-file in a format that can be loaded only by MATLAB versions 7.3 and above. This format, based on HDF5 files, is intended for saving FIG-files larger than 2 GB.

Backward Compatibility

When creating a figure you want to save and use in a MATLAB version prior to MATLAB 7, use the 'v6' option with the plotting function and the '-v6' option for hgsave. Check the reference page for the plotting function you are using for more information.

In MATLAB release R2014b or later, you cannot open a save FIG-file in earlier versions of MATLAB. Use savefig to save figures that are compatible with earlier versions of MATLAB.

Alternatives

Use the File > Export Setup dialog. Use Edit > Copy Figure to copy the figure's content to the system clipboard. For details, see Customize Figure Interactively Before Saving and Copy Figure to Clipboard from Edit Menu.

See Also

| | |

Introduced before R2006a

Was this topic helpful?